The last time Hackerfall tried to access this page, it returned a not found error. A cached version of the page is below, or click here to continue anyway

Intero for Emacs

Install package

Use Emacs's built in package manager. Add the following to your .emacs:

;; If you don't have MELPA in your package archives:
(require 'package)
(add-to-list
  'package-archives
  '("melpa" . "http://melpa.org/packages/") t)
(package-initialize)
(package-refresh-contents)

;; Install Intero
(package-install 'intero)
(add-hook 'haskell-mode-hook 'intero-mode)

Modern and backwards compatible

Tested on GHC 8.0.1, GHC 7.10.3, GHC 7.10.2, and GHC 7.8.4.

Backwards compatibility will be maintained as far back as is possible.

General backend

The Intero backend used by the Emacs mode is a fork of GHCi, it behaves like your old friend GHCi, but with more features.

Support for other editors is not promised, but patches are welcome.

Continue reading on commercialhaskell.github.io